LANネットワークの設定でつまずく

家のインターネットは妹が加入してるADSL、モデムはトリオモデム3-G plus
PA141282.jpg

無線アクセスポインタは、FON2405E
PA311366 (2)
可也インターネットの速度が遅かったが、chromeブラウザを使ってると、そんなに気にならず、そのままにしていた。
それよりも当初から気になってたのは、トリオ3Gの有線が100Mbpsで、LAN接続してるPC間の通信のネックになっていた事。
メインPCで録画した物を家族用PCでしょっちゅう再生するので、100Mbpsだと反応が鈍くてイライラする事があった。
1000MbpsのLANハブは以前から持ってたのだが、家の電話の周りは混雑してるので、気が引けて使わないでいた。
ある日お手頃価格の無線LANルーターの有線が1000Mbps化してるのに気づいたので、手を付ける事にした。

NEC Aterm PA-WG1200HS購入。
PA111272.jpg
小さくてFON2405Eと入れ替える事が出来て、有線が1000Mbps、要求にぴったり合ってる。
無線はFON2405Eに比べて電波が良く飛び、5GHz帯も使えるが、有線に問題が出た。
他の機器がネットワーク上に見えるのに、アクセスが出来ない。
偶にネットワーク上から他の機器が見えなくなったりする。
手動で1000Mbpsから100Mbpsに変更すると、不具合は無くなる。
メインPCに入ってるネットワークチップがインテル製なので、ネットワーク経路の診断をやってみたら、ケーブルの質が悪いか経路にある機器の設定が合ってないと出た。
試しに以前から持っていたLANハブ、コレガ CG-SW05GTXで繋いでみると、1000Mbpsで問題なくつながる。
PA141282 (3)
ネットワーク診断も問題無し。
PA-WG1200HSの設定をいじっても不具合が解消しないので、さっさとオークションで売り払って手放した。
高価な品物では無いのでこれ以上手を掛けても損するだけだ。

そしてもう一回試してみようと、今度はIOデーターのWN-AC1167GRを購入した。
PA311365 (2)
NEC Aterm PA-WG1200HSを選んだ理由は同性能の機器の中で一番小さかった事。
WN-AC1167GRはその次に小さい。
WN-AC1167GRはネットワーク診断して問題は無かった。
しかしネットワーク上の他の機器にアクセスしてみると、何故かアクセス出来ない。
再びCG-SW05GTXに戻すと、何の問題もなくアクセス出来る。
買ったルーター2台続けて不具合が出るのは、こちら側の問題の可能性が高い。
本腰入れて色々調べて不具合が解消した設定が以下。

インテルチップの場合:
LAN Intel setting1 LAN Intel setting2 LAN Intel setting3
節電オプションの「システムをウェイクアップせずに ARP 要求に応答する」、「システムをウェイクアップせずに NS 要求に応答する」、「システムのアイドル中にリンク速度を落とす」のチェックを外すのが重要。
ジャンボパケット対応と書いてない機器を挟む場合、ジャンボパケットは明示的に無効にしたほうが良いようだ。
WN-AC1167GRはジャンボパケット有効のままだと、応答が遅くなった。

Realtekチップの場合:
LAN Realtek setting1 LAN Realtek setting2 LAN Realtek setting3
ARPオフロード無効、NSオフロード無効、が重要。
Jumbo Frameは対応と書いてない機器を挟む場合は明示的にDisabled。
理由はインテルチップと同じ。

「システムをウェイクアップせずに ARP 要求に応答する」と「ARPオフロード」、「システムをウェイクアップせずに NS 要求に応答する」と「NSオフロード」は、同じ設定なのは察しが付くと思う。
オフロードとはCPUで処理せずにチップで処理するという事で、CPU負荷が下がり応答も速くなり消費電力も下がると良い事づくめのようだが、これのせいでネットワーク上に見えるのに、アクセス出来ないという事が起きるようだ。
LAN上の他の機器にアクセスする事がないのなら、このチェックを入れても問題は起きないはず。
また何故か100Mbps接続だと、このチェックを入れても問題が起きないようだ。
(今までチェックが入りっぱなしで問題なかった)
あとコレガ CG-SW05GTXではインテルの「システムをウェイクアップせずに ARP 要求に応答する」と「システムをウェイクアップせずに NS 要求に応答する」のチェックが入ってても1000Mbps接続で問題が出なかった。
どうやらオフロードの設定は機器との相性が激しいようだ。
新しい機器をつないで不具合が出たら最初に疑うべき設定だろう。

もしかしたらNEC Aterm PA-WG1200HSも、この辺の設定を変更すれば、問題なく動いたのかもしれない。
さっさと手放したのは早計だったが、まあいい。
動けばNECもIOデーターもコレガも体感に差は無いし、今回の金銭的な損もちょっとだ。

以上苦労したので、覚え書きに残しておく。

コメントの投稿

非公開コメント

最新記事
最新コメント
最新トラックバック
カテゴリ
月別アーカイブ
FC2カウンター
リンク
検索フォーム
RSSリンクの表示
ブロとも申請フォーム

この人とブロともになる

QRコード
QR